Função VLOOKUP (Procv) para procurar valores no Excel

Função VLOOKUP (Procv) para procurar valores no Excel
Ideias Chave
1. Usada para procurar valores com base num determinado parâmetro.
2. Explora mais informação sobre a alternativa ÍNDICE/CORRESP (Index/Match).

Resumo

A Função VLOOKUP (Procv) do Excel é usada para fazer buscas em linhas de uma tabela ou de um intervalo de valores. Por exemplo, numa lista de clientes, podemos pesquisar pelo ID de cada Cliente para ver as informações como nome, país, idade, género.

Função Vlookup (Procv)

A formulação da função é a seguinte:
=PROCV(valor_procurado;matriz_tabela;núm_índice_coluna;procurar_intervalo)
Vamos então decompor a função para perceber o que ela faz:

valor_procurado: é o valor que desejamos deseja encontrar;
Neste exemplo, queremos usar o ID do cliente da Célula $C$1. Os $ à volta do C1 bloqueiam esta célula.

matriz_tabela: é o intervalo onde o valor procurado está localizado. Será uma tabela ou um intervalo podendo ter duas ou mais colunas, e pode estar localizada em outra folha de cálculo;
A listagem de clientes que vai de $G$1:$K$14 (também bloqueada com $).

núm_índice_coluna: o número da coluna que contém o valor a ser retornado;
Neste intervalo de G1:K14, deve contar a coluna G como 1, a coluna H como 2 e assim sucessivamente.

procurar_intervalo: valor que determina se a busca será feita por uma correspondência exata ou aproximada do valor pesquisado;
Sendo FALSO (ou 0) para busca exata e VERDADEIRO (ou 1) para aproximado. Neste exemplo, é 0 porque buscamos os valores exactos.

No nosso exemplo, vamos procurar no intervalo que tem todos os dados, a informação do cliente 7

Procurar o cliente 7

Na célula C2 vamos inserir:
=PROCV($C$1;$G$1:$K$14;5;0)
em que:
C1 é a célula onde será inserida o ID do Cliente;
G1:K14 é o intervalo da tabela com os dados dos clientes;
2 é o número da coluna que contém a informação a ser retornada, sendo a coluna G a número 1, a coluna H a número 2, etc.;
0 é o parâmetro FALSO para realizar a busca por valores exactos;

Para exibir a informação das outras células, basta arrastar a fórmula e alterar os valores das colunas correspondentes (3 para retornar o País, 4 para retornar a Idade e 5 para retornar o Género).

Não te esqueças de bloquear o intervalo das células adicionando o "$" para que não mude ao arrastar a fórmula de uma célula para outra.

Descargas

Descarrega aqui o ficheiro com os exemplos para a função VLOOKUP (Procv) no Excel
Artigo anterior Artigo seguinte
Sem comentários
Comentar
url comentário

Pesquisa Google