Automatizar a coluna a procurar usando COLUMN (Col) no VLOOKUP (Procv)

Ideias Chave
1. Usar a Função COL (Column) para automatizar a coluna a procurar com o PROCV.

Problema

É bastante provável que uma das funções que mais utilizas no Excel seja o PROCV (Vlookup). Quando trabalhamos com o PROCV inserimos o número da coluna que buscamos mas quando arrastamos a fórmula esse número da coluna não se actualiza e a fórmula fica presa na coluna que inserimos manualmente.

Pesquisa com procv
=PROCV($B$3;$B$7:$F$20;2;0)
Neste exemplo estamos a dizer que queremos procurar o Nome do Cliente na coluna 2.

Arrastar a fórmula procv

Se arrastarmos a coluna para o lado, continuamos a procurar na coluna 2. E não é isso que pretendemos. O que queremos é que a fórmula se automatize de forma a que quando a arrastamos a coluna de busca se actualize também para a coluna seguinte.

A solução que propomos

Em vez de usarmos o número da coluna, propomos que uses a Função COL (Column) para que quando arrastares a fórmula actualizes também a coluna de busca.

Automatizar o campo da coluna a pesquisar
=PROCV($B$3;$B$7:$F$20;COL(B1);0)
Desta forma em vez de indicarmos a coluna escrevendo directamente 2, automatizamos a fórmula explicando ao Excel que queremos a coluna B desta seleção de dados. Muito importante ter em atenção que o COL(B1), neste exemplo, não corresponde à coluna B da Planilha mas sim à 2ª coluna da tabela de dados que estamos a trabalhar e que neste caso concreto está posicionada na coluna C da Planilha.

=PROCV($B$3; // o valor que queremos procurar

$B$7:$F$20; // a tabela de dados em que queremos procurar o valor. Importante fixar com $ para que quando arrastamos a tabela se mantenha

COL(B1); // definimos a coluna, sendo que COL(B1) neste caso irá identificar a 2ª coluna do nosso campo de dados

0) // o parâmetro FALSO para realizar a busca por valores exactos

Descargas

Descarrega aqui o ficheiro com os exemplos para automatizar a coluna a procurar com VLOOKUP (Procv) e COLUMN (Col)
Artigo anterior Artigo seguinte
Sem comentários
Comentar
url comentário

Pesquisa Google