Função PROCX (Xlookup) Pesquisa com Correspondência Exacta

Procx com correspondencia exacta

Resumo

Introduzida como novidade no Excel 365, a função PROCX (Xlookup) procura por uma correspondência num intervalo ou matriz de dados e devolve o valor correspondente de um segundo intervalo ou matriz. A predefinição desta função é a correspodência exacta.

Descobre com mais detalhe as novidades do PROCX (Xlookup) e as principais diferenças face às funções PROCV (Vlookup), PROCH (Hlookup) e PROC (Lookup).

Exemplo de PROCX com Correspondência Exacta

PROCX com correspondência exacta
=PROCX(J5;B5:B17;D5:D17)
Esta é a versão mais simples do PROCX (Xlookup) feita com as variáveis mínimas para a função correr. Neste exemplo, J5 é igual ao Cliente "2", pelo que vamos pedir ao Excel que na matriz de pesquisa "B5:B17" procure por este valor. E que devolva o valor correspondente na matriz de valores a devolver "D5:D17". Neste caso, "2" irá devolver o valor "Angola".

Sintaxe

=ÍNDICE (Valor_pesquisa; Matriz_pesquisa; Matriz_devolver)

Argumentos

Valor_pesquisa // Valor a procurar
Matriz_pesquisa // Matriz ou intervalo a procurar
Matriz_devolver // Matriz ou intervalo a devolver

PROCX (Xlookup) vs PROCV (Vlookup)

As principais melhorias face ao PROCV (Vlookup) são:

O PROCV necessita que especifiquemos uma tabela completa na matriz (matriz_tabela).
O PROCV obriga a que indiquemos o índice da coluna a devolver (núm_índice_coluna).
O PROCV assume a pesquisa aproximada como predefinição o que pode causar erros no valor devolvido (procurar_intervalo).
Alerta
A função PROCX (Xlookup) apenas está disponível a partir do EXCEL 365.
Explora com mais detalhe todas as potencialidades do PROCX (Xlookup).

Descargas

Descarrega aqui o ficheiro com os exemplos para usar a pesquisa com correspondência exacta do XLOOKUP
Artigo anterior Artigo seguinte
Sem comentários
Comentar
url comentário

Pesquisa Google