Função PROCX (Xlookup) Pesquisa com Valores Múltiplos Devolvidos

Pesquisa com valores múltiplos

Resumo

Introduzida como novidade no Excel 365, a função PROCX (Xlookup) procura por uma correspondência num intervalo ou matriz de dados e devolve o valor correspondente de um segundo intervalo ou matriz. A predefinição desta função é a correspodência exacta.

Descobre com mais detalhe as novidades do PROCX (Xlookup) e as principais diferenças face às funções PROCV (Vlookup), PROCH (Hlookup) e PROC (Lookup).

Exemplo de PROCX com Pesquisa com valores multiplos devolvidos

PROCX com valores múltiplos devolvidos
=PROCX(J5;B5:B17;D5:F17;;-1)

Síntaxe

=ÍNDICE (Valor_pesquisa; Matriz_pesquisa; Matriz_devolver)

Argumentos

Valor_pesquisa // Valor a procurar
Matriz_pesquisa // Matriz ou intervalo a procurar
Matriz_devolver // Matriz ou intervalo a devolver
Modo_corresp // especifica como deve ser feita a correspondência do valor_pesquisa com a matriz_pesquisa [OPCIONAL]
Modo_pesquisa // especifica o modo de pesquisa a usar. A predefinição é pesquisa do primeiro ao último elemento [OPCIONAL]

Racional

Se alargarmos o intervalo da "Matriz_devolver" conseguimos que a função devolva todos os valores correspondentes nessa linha (ou coluna).

D5:F17; // ao extendermos "D5:D17" para "D5:F17", estamos a dizer à fórmula que devolva os valores das Colunas "D", "E" e "F"

;; // se não encontrar nenhum valor devolve a célula vazia. Não colocámos nenhum texto de aviso, por exemplo "Nenhum valor" [OPCIONAL]

;-1) // modo de correspondência -1, ou seja, pesquisa exata ou o valor menor mais próximo [OPCIONAL]

Descargas

Descarrega aqui o ficheiro com os exemplos para usar a pesquisa com valores múltiplos devolvidos do XLOOKUP
Artigo anterior Artigo seguinte
Sem comentários
Comentar
url comentário

Pesquisa Google