Função PROCX (Xlookup) Pesquisa por Dois Valores

Pesquisa por dois (2) valores

Resumo

Introduzida como novidade no Excel 365, a função PROCX (Xlookup) procura por uma correspondência num intervalo ou matriz de dados e devolve o valor correspondente de um segundo intervalo ou matriz. A predefinição desta função é a correspodência exacta.

Descobre com mais detalhe as novidades do PROCX (Xlookup) e as principais diferenças face às funções PROCV (Vlookup), PROCH (Hlookup) e PROC (Lookup).

Exemplo de PROCX com Pesquisa por 2 valores

PROCX com pesquisa por dois valores
=PROCX(J6;C4:F4;PROCX(J5;B5:B17;C5:F17))

Síntaxe

=ÍNDICE (Valor_pesquisa; Matriz_pesquisa; Matriz_devolver)

Argumentos

Valor_pesquisa // Valor a procurar
Matriz_pesquisa // Matriz ou intervalo a procurar
Matriz_devolver // Matriz ou intervalo a devolver

Racional

No argumento "Matriz_devolver" encadeamos outro PROCX (Xlookup) e desta forma conseguimos que a pesquisa inclua duas variáveis.
=PROCX(J6; // no primeiro argumento "Valor_pesquisa" indicamos que queremos procurar o cliente "4" ;PROCX(J5;B5:B17;C5:F17)) // dentro da "Matriz_devolver" vamos dizer à função inicial que deve executar um novo PROCX (Xlookup) que irá procurar pela "Idade" do "Cliente 4"

Descargas

Descarrega aqui o ficheiro com os exemplos do artigo para pesquisar por dois valores com XLOOKUP
Artigo anterior Artigo seguinte
Sem comentários
Comentar
url comentário

Pesquisa Google