Introdução a Fórmulas e Funções no Excel

Introdução a Fórmulas e Funções no Excel – Parte 1 de 3

Fórmulas

Vamos abordar a utilização de Funções e Fórmulas, uma das principais componentes do Excel, e de que forma as podemos utilizar para explorar todas as potencialidades das folhas de cálculo.

Uma fórmula é uma expressão que opera sobre valores numa célula ou num conjunto de células. Estas operações podem ser algo como simples cálculos aritméticos: adição, subtração, multiplicação ou divisão. Ou podem, por exemplo, ser operações matemáticas mais complexas que conjugam diversos tipos de cálculos e elementos.

As fórmulas, dependendo da sua complexidade, podem ser mais ou menos extensas e são compostas pelos seguintes elementos: operandos, operadores e funções.

Funções, operadores e operandos no Excel

Operandos

Um operando é um valor usado nas fórmulas que pode ser numérico, alfanumérico ou um símbolo. Nenhum deles é mutuamente exclusivo. A fórmula pode ser uma conjugação dos três tipos de valores dos operandos. De forma muito simples, os operandos são os valores usados para os cálculos nas fórmulas.

Operadores

Os operadores definem a relação e as acções que vao ocorrer entre os operandos. Há quatro tipos de operadores no Excel:

Operadores de Aritmética
Operadores Lógicos e de Comparação
Operadores de Concatenação de texto
Operadores de Referência

Operadores Aritméticos

Usados para realizar operações matemáticas básicas como Adição, Subtração, Multiplicação e Divisão, Produzir Resultados Numéricos ou Combinar números.
AritméticaDescriçãoExemplo
+Adição=4+4 (8)
-Subtração=4-4 (0)
Negação=-4
*Multiplicação=4*4 (16)
/Divisão=4/4 (1)
%Por cento30%
^Exponenciação=4^4 (256)

Operadores Lógicos e de Comparação

Usado para comparar valores. Quando os valores são comparados com algum destes operadores, o resultado devolvido é um valor lógico – VERDADEIRO ou FALSO.
Comparação e LógicaDescriçãoExemplo
=Igual a=A2=B2
>Maior que=A2>B2
<Menor que=A2
>=Maior ou igual a=A2>=B2
<=Menor ou igual a=A2<=B2
<>Diferente de=A2<>B2

Operadores de Concatenação de Texto

O E Comercial (ampersand) "&" é usado para juntar (o termo do Excel é Concatenar) um ou mais conjuntos de texto produzindo um texto único.
ConcatenaçãoDescriçãoExemplo
&Concatena (junta) dois valores para produzir um valor de texto contínuo="Para" e "Raios" resultam em "ParaRaios". Exemplo: =A1&B1 ou ="Para"&"Raios"

Operadores de Referência

Permitem combinar intervalos de células para cálculo.
ReferênciaDescriçãoExemplo
:Devolve uma referência de todas as células entre duas determinadas referências; incluindo essas duas referências de início e de fecho (neste exemplo A1 e A10).=SOMA(A1:A10)
, ou ;Devolve uma referência de união, combinando vários intervalos em uma referência=SOMA(A1:A10,B1:B10)

Funções

Funções são fórmulas pré-definidas do Excel e o seu papel é ajudar a simplificar o trabalho do utilizador. Para quê inserir cálculos à mão se podemos usar Funções mais curtas e mais simples para fazer o mesmo?

Função soma

As funções funcionam como atalhos que nos ajudam a fazer o que queremos mais rápido e com menos código. Podemos em vez de escrever o nome de todas as células, usar a função SOMA (SUM) para fazer exactamente o mesmo, =SUM(A1:A3). A função soma os valores das células de A1 a A3.

Ordens de Precedência no Excel

O Excel segue regras gerais da matemática que são fundamentais para entender a precedência dos cálculos. PEMDAS é um acrónimo para (1) Parêntesis, (2) Expoentes, (3) Multiplicação (ou) Divisão, (4) Adição (ou) Subtração. Quando temos pelo menos duas operações numa equação, a ordem das letras ajuda-nos a saber a ordem de resolução até chegarmos à resolução final da equação.

Por exemplo, se tivermos parêntesis na equação, vamos resolver primeiro o interior dos parêntesis e depois tratar o resto da equação. Sem esta regra base não haveria uma resposta única para a equação pois haveriam diferentes interpretações à forma de abordar a resolução.

1.

Parêntesis primeiro

6 × (9 + 6) = 6 × 15 = 90 Correcto
6 × (9 + 6) = 54 + 6 = 60 Incorrecto

2.

Expoentes (Potências, Raízes) antes de multiplicar, dividir, somar ou subtrair

10 × 2^2 = 10 × 4 = 40 Correcto
10 × 2^2 = 20^2 = 400 Incorrecto

3.

Multiplicar ou Dividir antes de Somar ou Subtrair

5 + 6 × 3 = 5 + 18 = 23 Correcto
5 + 6 × 3 = 11 × 3 = 33 Incorrecto

Se os elementos forem apenas multiplicar e dividir, seguimos da esquerda para a direita, pois têm a mesma prioridade.

45 ÷ 5 × 3 = 9 × 3 = 27 Correcto
45 ÷ 5 × 3 = 45 ÷ 15 = 3 Incorrecto

Mas se houver parêntesis, muda a forma de resolver a equação.

45 ÷ (5 × 3) = 45 ÷ 15 = 3 Correcto

4.

Somar ou Subtrair

Somar e subtrair têm a mesma prioridade entre si, ou seja, numa equação apenas com somas e subtrações resolvemos da esquerda para a direita.

10 - 5 + 3 = 5 + 3 = 8 Correcto

Mensagens de Erro

Mensagens de erro dariam por si só para um tutorial próprio. Nesta lição vamos apenas nomear algunss dos erros mais comuns e que poderão surgir na lição seguinte em que partilhamos alguns exemplos de fórmulas e funções do Excel.

Mensagens de erro no Excel

Erro ###

Quando uma coluna não é larga o suficiente para mostrar o resultado da fórmula no seu interior, o Excel apresenta a mensagem de erro ###. Alargando a coluna o erro desaparece mostrando o conteúdo da célula.

Erro #NAME?

Quando o texto da fórmula não é reconhecido como o nome de uma função. Ex.: SUMM em vez de SUM

Erro #DIV/0!

Quando um número é dividido por zero, o Excel não entende qual o valor dessa célula.

Erro #VALUE!

Quando a fórmula inclui tipos de dados não compatíveis entre si. Ex.: Não é possível multiplicar números por texto.

Erro #REF!

Quando o valor de referência na célula não é válido. Ocorre, por exemplo, quando apagamos linhas ou colunas que estão referenciadas na determinada fórmula.

Erro #NUM

Quando a fórmula contém um número inválido, por exemplo, a raíz quadrada de um número negativo.

Descargas

Descarrega aqui o ficheiro com os exemplos de fórmulas e funções do Excel

Artigo anterior Artigo seguinte
Sem comentários
Comentar
url comentário

Pesquisa Google