Função PROCX (Xlookup) Pesquisa com Correspondência Aproximada

Procx com correspondencia aproximada

Resumo

Introduzida como novidade no Excel 365, a função PROCX (Xlookup) procura por uma correspondência num intervalo ou matriz de dados e devolve o valor correspondente de um segundo intervalo ou matriz. A predefinição desta função é a correspodência exacta.

Descobre com mais detalhe as novidades do PROCX (Xlookup) e as principais diferenças face às funções PROCV (Vlookup), PROCH (Hlookup) e PROC (Lookup).

Exemplo de PROCX com Correspondência Aproximada

PROCX com correspondência aproximada

Valor menor mais próximo
=PROCX(J5;B5:B17;D5:D17;;-1)
Valor maior mais próximo
=PROCX(J5;B5:B17;D5:D17;;1)
Nesta aplicação da função PROCX (Xlookup) acrescentamos uma variável extra à função quando comparado com a versão mais básica da função. Vamos dizer ao Excel que caso não encontre o valor exacto que estamos a procurar, deve devolver o valor imediatamente abaixo ou acima.

No nosso exemplo, vamos procurar pelo cliente "10". Mas este cliente não existe. Desta forma, usando a variável que define o modo de correspondência indicamos ao Excel que se o valor procurado ("10") não existir, deve devolver o valor imediatamente abaixo se usarmos o critério "-1" ou o valor imediatamente acima se usarmos o valor "1" no modo de correspondência.

Opções modo de Correspondência:
Valor Resultado
0 [é o valor por defeito] Pesquisa Exata. Se não encontrar o valor devolve erro (#N/D)
-1 Pesquisa Exata ou o valor menor mais próximo.
1 Pesquisa Exata ou o valor maior mais próximo.
2 Pesquisa com wildcards (*, ?, ~)
Revendo o exemplo, se usarmos "-1" como critério de correspondência, a função devolverá "Moçambique" correspondendo ao valor encontrado "8" (pois não existe o "10"). Se usarmos o critério "1", a função devolve "Cabo Verde" correspondente ao valor "12".

Síntaxe

=ÍNDICE (Valor_pesquisa; Matriz_pesquisa; Matriz_devolver; ; Modo_corresp)

Argumentos

Valor_pesquisa // Valor a procurar
Matriz_pesquisa // Matriz ou intervalo a procurar
Matriz_devolver // Matriz ou intervalo a devolver
; ; // argumento [se_não_for_encontrado] não usado nesta solução.
Modo_corresp // Especifica como é feita a correspondência do valor do campo Valor_pesquisa com os valores da Matriz_pesquisa [OPCIONAL]

PROCX (Xlookup) vs PROCV (Vlookup)

As principais melhorias face ao PROCV (Vlookup) são:

O PROCV necessita que especifiquemos uma tabela completa na matriz (matriz_tabela).
O PROCV obriga a que indiquemos o índice da coluna a devolver (núm_índice_coluna).
O PROCV assume a pesquisa aproximada como predefinição o que pode causar erros no valor devolvido (procurar_intervalo).
Alerta
A função PROCX (Xlookup) apenas está disponível a partir do EXCEL 365.
Explora com mais detalhe todas as potencialidades do PROCX (Xlookup).

Descargas

Descarrega aqui o ficheiro com os exemplos para usar a pesquisa com correspondência aproximada do XLOOKUP
Artigo anterior Artigo seguinte
Sem comentários
Comentar
url comentário

Pesquisa Google