O que são e como usar os Operadores de Cálculo do Excel

O que são e como usar os Operadores de Cálculo do Excel

Resumo

Os Operadores de Cálculo especificam os tipos de cálculo que queremos realizar com os elementos da Fórmula seguindo as regras gerais da Matemática para os efectuar, nomeadamente as regras PEMDAS: Parêntesis, Expoentes, Multiplicação e Divisão, Adição e Subtração.

As Fórmulas mais simples de Excel não são mais que cálculos realizados utilizando apenas os Operadores com os quais indicamos ao Excel o que queremos calcular entre células diferentes.

Operadores de Cálculo

Há quatro tipos básicos de Operadores de Cálculo:

1. Operadores de Aritmética
2. Operadores Lógicos e de Comparação
3. Operadores de Concatenação de texto
4. Operadores de Referência

1. Operadores Aritméticos

Usados para realizar operações matemáticas básicas como Adição, Subtração, Multiplicação e Divisão, Produzir Resultados Numéricos ou Combinar números.
AritméticaDescriçãoExemplo
+Adição=4+4 (8)
-Subtração=4-4 (0)
Negação=-4
*Multiplicação=4*4 (16)
/Divisão=4/4 (1)
%Por cento30%
^Exponenciação=4^4 (256)
Os Aritméticos permitem-nos realizar cálculos na construção de fórmulas simples mas também são fundamentias para construir fórmulas mais complexas com uma ou mais Funções.

Ao conjugar operadores aritméticos distintos numa única fórmula é importante garantir que a precedência é seguida. O Excel segue a ordem definida de precedência dos operadores, por exemplo: multiplicação e divisão têm predência sobre adição e subtração.
=1+4-2*3 = -1
Ao usarmos parêntesis "()" indicamos ao Excel que as operações no seu interior têm prioridade sobre as restantes operações que (sem os parêntesis) seriam realizadas primeiro.
=1+(4-2)*3 = 7
Os parêntesis "()" são muito importantes. Podem não surtir o efeito que queremos e dependem da conjugação dos cálculos realizados
=(1+4)-2*3 = -1
Se usarmos operadores com o mesmo nível de precedência, por exemplo adição e subtração, o Excel avalia cada elemento da equação da esquerda para a direita.
=(1+4-2)*3 = 9

2. Operadores Lógicos e de Comparação

Usado para comparar valores. Quando os valores são comparados com algum destes operadores, o resultado devolvido é um valor lógico – VERDADEIRO ou FALSO.
Comparação e LógicaDescriçãoExemplo
=Igual a=A2=B2
>Maior que=A2>B2
<Menor que=A2
>=Maior ou igual a=A2>=B2
<=Menor ou igual a=A2<=B2
<>Diferente de=A2<>B2
Os operadores de comparação produzem apenas o valor lógico VERDADEIRO ou o valor lógico FALSO e a sua utilização é muito comum com a Função SE (If) para construir fórmulas complexas e cujo o resultado varia conforme o resultado do valor lógico.
=SE (teste_lógico; [valor_se_verdadeiro]; [valor_se_falso])
teste_lógico // um valor ou uma expressão lógica que pode ser avaliada como VERDADEIRA ou FALSA
valor_se_verdadeiro // o valor a atribuir se o teste lógico devolver VERDADEIRO
valor_se_falso // o valor a atribuir se o teste lógico devolver FALSO

Mais detalhe sobre como usar a Função SE (If) no Excel

3. Operadores de Concatenação de Texto

O E Comercial (ampersand) "&" é usado para juntar (o termo do Excel é Concatenar) um ou mais conjuntos de texto produzindo um texto único.
ConcatenaçãoDescriçãoExemplo
&Concatena (junta) dois valores para produzir um valor de texto contínuo="Para" e "Raios" resultam em "ParaRaios". Exemplo: =A1&B1 ou ="Para"&"Raios"

4. Operadores de Referência

Permitem combinar intervalos de células para cálculo.
ReferênciaDescriçãoExemplo
:Devolve uma referência de todas as células entre duas determinadas referências; incluindo essas duas referências de início e de fecho (neste exemplo A1 e A10).=SOMA(A1:A10)
, ou ;Devolve uma referência de união, combinando vários intervalos em uma referência=SOMA(A1:A10,B1:B10)

Ideias Chave

1. Regras Gerais da Matemática para Cálculos (PEMDAS)
2. Operadores Aritméticos servem para fazer Cálculos
3. Operadores de Comparação devolvem resultado Verdadeiro ou Falso e são muito usados com a Função SE (If)
4. Operadores de Concatenação juntam vários textos em apenas um texto
5. Operadores de Referência combinam intervalos para um cálculo
Artigo anterior Artigo seguinte
2 Comentários
  • RIVA
    RIVA 6/10/21

    Excelente artigo!

    • João
      João 7/1/22

      Obrigado pelo apoio Riva!

      @exceltuga

Comentar
url comentário

Pesquisa Google